发布于 2017-07-16 14:08:01 | 52 次阅读 | 评论: 0 | 来源: 网友投递

这里有新鲜出炉的Ruby教程,程序狗速度看过来!

Ruby编程语言

Ruby,一种为简单快捷的面向对象编程(面向对象程序设计)而创的脚本语言,在20世纪90年代由日本人松本行弘开发,遵守GPL协议和Ruby License。它的灵感与特性来自于 Perl、Smalltalk、Eiffel、Ada以及 Lisp 语言。


这篇文章主要介绍了Ruby on rails安装后去掉DL is deprecated,please use Fiddle警告信息的方法,通过针对Ruby on rails安装文件中的警告部分源码进行注释来达到消除警告的目的,需要的朋友可以参考下

本文实例讲述了Ruby on rails安装后去掉DL is deprecated,please use Fiddle警告信息的方法。分享给大家供大家参考,具体如下:

问题:

搭建完完ruby on rails环境之后发现每次运行命令总会有这样一个Warning:DL is deprecated, please use Fiddle,例如:

对运行什么的没有影响,只是Dl过时了,可是Ruby大大不管这个问题,可是看着就烦呐~~

解决方法from stackflow):

找到安装目录D:\RailsInstaller\Ruby2.1.0\lib\ruby\2.1.0下的dl.rb将里面的warn一行注释掉即可:


require 'dl.so'

begin
 require 'fiddle' unless Object.const_defined?(:Fiddle)
rescue LoadError
end

#warn "DL is deprecated, please use Fiddle"

module DL
 # Returns true if DL is using Fiddle, the libffi wrapper.
 def self.fiddle?
  Object.const_defined?(:Fiddle)
 end
end

终于我们的世界又清净了许多!

希望本文所述对大家Ruby on rails程序设计有所帮助。



相关阅读 :
Ruby on rails安装后去掉DL is deprecated,please use Fiddle警告信息的方法【测试可用】
windows下安装ruby与rails时遇到的问题总结
openSUSE下的Ruby安装openssl出错解决方法
ruby安装gem包失败的通用解决方法
Ruby在cmd下中文显示乱码以及不支持OpenSSL的问题解决
Rails应用程序中同时修改操作冲突问题的解决方案
rails "No route matches" 错误的解决方法
最新网友评论  共有(0)条评论 发布评论 返回顶部

Copyright © 2007-2017 PHPERZ.COM All Rights Reserved   冀ICP备14009818号  版权声明  广告服务